登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

lgjmfyx的博客

享受生活每一天

 
 
 

日志

 
 

1个IP 映射多个网站(此方法非常巧妙 可以举一反三)  

2009-03-05 16:57:41|  分类: 默认分类 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

1个IP 映射多个网站(此方法非常巧妙 可以举一反三) 1个IP 映射多个网站(此方法非常巧妙 可以举一反三)
作者:佚名 点击数: 228 更新:2009-2-26 22:10:25          ★★★ 收藏到QQ书签



和进阶2 http://www.szwblm.com/Route/ShowArticle.asp?ArticleID=45380

这个功能非常巧妙

能最大化的利用我们的公网IP 来做1些我们想做的事情

===============================

注意: 目前这个应用仅仅是针对HTTP 连接 (而且必须做有透明代理才能用到),如果是 HTTPS 连接则无法成功


案例: 我只有1个公网IP,但是我希望能做成一下效果客户访问我的3个网站 都能去到我内网的3个不同服务器上面 。公网IP 56.57.58.59/30

希望做成这样:

123.com@192.168.0.2
abc.com@192.168.0.3
456.com@192.168.0.4

首先我们回顾1下进阶1的透明代理
1.
/ip web-proxy
set enabled=yes src-address=0.0.0.0 port=8080 hostname="Legou.proxy" \
transparent-proxy=yes parent-proxy=0.0.0.0:0 \
cache-administrator="QQ contact 1980469" max-object-size=4096KiB cache-drive=system \
max-cache-size=unlimited max-ram-cache-size=unlimited

/ip web-proxy access
add dst-port=23-25 action=deny comment="block telnet spam e-mail relaying" \
disabled=no
add dst-port=80 action=allow comment="Enable Http Connection"
(增加1句允许访问内网这个 透明代理服务器)

2.这个是关键 配置静态的 DNS 指向相关的服务器
/ip dns static add address=192.168.0.2
/ip dns static add address=192.168.0.3
/ip dns static add address=192.168.0.4
/ip dns static add address=192.168.0.2
/ip dns static add address=192.168.0.3
/ip dns static add address=192.168.0.4


3. 最后这步如果你不看就能做好证明你对整个ROS 映射理解得很好
/ip firewall nat
add chain=dstnat in-interface=outside dst-address=56.57.58.59 protocol=tcp \
dst-port=80 action=redirect to-ports=8080 comment=""

希望这些知识能帮助到大家在日常的使用管理 ROS
有更好的方法可以告诉我
我想你们能找到我的联系方式的



引文来源  1个IP 映射多个网站(此方法非常巧妙 可以举一反三)



引文来源  1个IP 映射多个网站(此方法非常巧妙 可以举一反三) - cwhai的日志 - 网易博客
  评论这张
 
阅读(483)| 评论(0)

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018